Customer Login
Welcome, Guest
Username Password: Remember me
Change your voice in voice chat rooms, PC-to-phone connections, online games
  • Page:
  • 1

TOPIC: Echoing through VoizGame

Echoing through VoizGame 1 year, 10 months ago #7877

I keep hearing my friends voice coming through in the VoizGame application. Similarly when I talk through it, there's an Echo. Is there a way to fix this?

Re: Echoing through VoizGame 1 year, 10 months ago #7878

  • Gabriella V
  • OFFLINE
  • Administrator
  • Posts: 466
  • Karma: 3
Hi Truc,

Regarding your problem, to avoid the echo/static, we recommend you to try the following settings:

  • Right-click on the Speaker icon at the bottom-right of your desktop » Choose Recording devices » Make sure that your microphone is set as Default
  • Double-click on your microphone » Switch to Listen tab » Uncheck "Listen to this device"
  • Click OK to save changes and close Sound window


Please notice that if you are using a laptop comes along with built-in microphone, it is recommended to disable the built-in microphone and use a headset that plugged directly into your sound card's port instead.

Also, please try turning off the Duplex button. The Duplex button has 2 modes: ON and OFF. When the Duplex is ON, you can hear your changed voice output. When Duplex button is OFF, your changed voice is muted. However, if you are doing voice chatting or making Internet phone, rest assured that the person at the other end will always hear your morphed voice whether the Duplex button is turned on or off.
  • Page:
  • 1
Time to create page: 0.11 seconds
  • Build updates
  • Recently added topics